お問い合わせ

VS Codeで「利用できるクイックフィックスはありません」というエラーが出たら

IT備忘録

ぱらげです。

VS CodeでLaravelの実装時に「利用できるクイックフィックスはありません」という不可解なエラーが。しかし、どこをよく見てもコーディングミスしているわけではない…

いろいろ調べてみてわかったのが、VS Codeの拡張機能であるPHP Intelephense1.3.11のバグであることがわかりました。

参考:stackoverflow_visual studio code php intelephense keep showing not necessary error

一番左下の拡張機能のアイコンを選択し、Intelephenseで検索。

PHP Intelephense右横の歯車マークを右クリックし、別のバージョンをインストール…」で1.2.3をインストールし、再読み込みしたら直りました。

コメント

タイトルとURLをコピーしました